Telegram ends support for vintage Android 2.2, 2.3 and 3.0 versions

Popular messaging app Telegram has quietly ended support for some older Android versions. Android 4.0 Ice Cream Sandwich is the minimum operating system version required to run Telegram’s latest version.

The reason behind the move hasn’t been officially revealed, but it’s be reasonable to assume that the step has been taken to smoothly update the app with new features that require a newer level of API that comes with the new releases.

In WhatsApp’s cull, iOS 6 support was also removed; luckily for Telegram users still running iOS 6, updates will still be provided for the time being. Although not mentioned by Telegram, their motives for ending support of such old platforms is to enable the software to get more features which require a new operating system.